Настройка PPPoA

Search Коммутация Настройка PPPoA Cisco - Коммутация

Принцип настройки PPPoA не сильно отличается от настройки PPPoE. Необходимо настроить ATM интерфейс с PVC (Permanent Virtual Circuit) SVC (Switched Virtual Ciscuit - dial-on-demand). Трафик должен пройти через CPE к оборудованию DSLAM далее по ATM к aggregation router. PPPoA использует протокол AAL5.

PPPoA использует RFC 1483/2684 инкапсуляцию внутри ATM ячеек для транспортировки PPP фреймов через DSL. Для поддержки PPP соединения используется логический интерфейс. Этот логический интерфейс будет ассоциирован с ATM PVC сконфигурированном на ATM интерфейсе. Такая конфигурация инкапсулирует каждое PPP соединение в отдельное PVC или SVC.

PPP over AAL5 соединения.

Существует три типа настройки PPPoA

  • Virtual circuit multiplexer PPP over AAL5 (AAL5VCMUX)
    Не является IP совместимой и разрабатывалась для поддержки протоколов IPX и AppleTalk
    Структура фрейма имеет следующий вид

    PPP padding используется только для поддержки MTU. Protocol ID показывает какой протокол верхнего уровня инкапсулирован.
    Создает виртуальную цепь для каждого протокола.
  • LLC encapsulated PPP over AAL5 (AAL5SNAP)
    Использует одну виртуальную цепь для транспортировки всех протоколов.
    Для реализации этого потребовалось дополнительно переносить информацию в ATM Common Part Convergence Subleyer-Protocol Data Unit (CPCS-PDU). Поэтому дополнительно используется Logical Link Control (LLC) инкапсуляция.

    В структуре фрейма PPP фрейм инкапсулирован в LLC заголовок, который обеспечивает указание номера протокола.
    LLC заголовок содержит:
    -Destination service access point (DSAP) - используется для OSI протоколов, таких как CLNS.
    -Sorce service access point (SSAP)
    -Frame type - определяет тип фрейма
    NLPID не является частью LLC заголовка, а ассоциирован с SNAP заголовком. Значение 0xCF указывает что используется LLC инкапсуляция для определения PPP.
  • Cisco PPP over ATM (PPPoA)
    Несколько PVC могут быть сконфигурированы на несколько sub интерфейсах, что значительно увеличивает кол-во PPPoA сессий запущеных на роутере.

Стандарт RFC 2364 определяет AAL5VCMUX и AAL5SNAP. Cisco PPPoA является проприетарной фичей.

Настройка ATM интерфейса для PPPoA

interface Ethernet 0/0
description =Subscriber-face=
ip address 172.16.0.1 255.255.0.0

AAL5MUX конфигурация

interface ATM0/0
no ip address
dsl operating-mode auto
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1

Если явно не указать инкапсуляцию, то по умолчанию выберется aal5snap. Также указана команда dsl operating-mode auto для автоматического определения метода DSL модуляции.

interface ATM0/0
no ip address
dsl operating-mode auto
interface ATM0/0.1 multipoint
class-int ppp-default
pvc 8/35
!
vc-class atm ppp-default
encapsulation aal5snap
protocol ppp virtual-template 1
ubr 256
!
Этот пример показывает настройку с использованием virtual-template интерфейса. Virtual-template интерфейс используется для входящих соединения и обеспечивает передачу опций на подконтрольный интерфейс. Как и Dialer интерфейс virtual-template интерфейс конфигурируется с теми же PPP характеристиками и параметрами.

!
interface virtual-template1
encapsulation ppp
ip address negotiated
ip nat outside
ppp authentication chap
ppp chap hostname Этот e-mail адрес защищен от спам-ботов, для его просмотра у Вас должен быть включен Javascript
ppp chap password 0 cisco
!

Настройка PPPoA через Dialer интерфейс выглядит следующим образом:

!
interface ATM0/0
no ip address
dsl operating-mode auto
pvc 8/35
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 1
!

По этой конфигурации Dialer интерфейс получает ip адрес от провайдера. Команда dialer pool ассоциирует Dialer и ATM интерфейсы.

Итак получаем общую конфигурацию для CPE роутера:

no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname PPPoA-CPE
!
memory-size iomem 5
enable secret 5 [removed]
!
username Emma privilege 15 secret 5 [removed]
username Amanda privilege 15 secret 5 [removed]
clock timezone est -6
clock summer-time cdt recurring
no aaa new-model
ip subnet-zero
no ip domain lookup
ip domain name mydomain.com
ip name-server 4.2.2.1
!
ip dhcp excluded-address 172.16.0.1 172.16.0.9
!
ip dhcp pool PCLAN
import all
network 172.16.0.0 255.255.0.0
default-router 172.16.0.1
!
interface Ethernet0/0
description ***Internal Private Network***
ip address 172.16.0.1 255.255.0.0
ip nat inside
!
interface ATM0/0
no ip address
dsl operating-mode auto
! Auto detect Modulation method
!
interface ATM0/0.1 multipoint
class-int ppp-default
!  Configure interface characteristics
pvc 8/35
!
interface virtual-template1
! Configures virtual-template
encapsulation ppp
ip address negotiated
ip nat outside
!
vc-class atm ppp-default
! Class sets circuit characteristics
encapsulation aal5snap
protocol ppp virtual-template1
! Ties circuit to virtual-template
ubr 256
!
ip classless
ip route 0.0.0.0 0.0.0.0 interface virtual-template1
no ip http server
no ip http secure-server
ip nat inside source list 100 interface virtual-template1 overload
!
access-list 100 permit ip 172.16.0.0 0.0.255.255 any
!
line con 0
exec-timeout 0 0
login local
line aux 0
line vty 0 4
exec-timeout 240 0
login local
!
scheduler max-task-time 5000
ntp peer 172.16.1.50
ntp server XXX.118.25.3 prefer
!
End

А также конфига при использовании AAL5MUX инкапсуляции:

no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname PPPoA-837
!
boot-start-marker
boot-end-marker
!
memory-size iomem 5
logging buffered 65536 debugging
enable secret 5 [removed]
!
username Emma privilege 15 secret 5 [removed]
username Amanada privilege 15 secret 5 [removed]
clock timezone est -6
clock summer-time cdt recurring
no aaa new-model
ip subnet-zero
no ip domain lookup
ip domain name mydomain.com
ip name-server 4.2.2.1
!
ip dhcp excluded-address 172.16.0.1 172.16.0.9
!
ip dhcp pool LAN_HOSTS
import all
network 172.16.0.0 255.255.0.0
default-router 172.16.0.1
dns-server 4.2.2.1
domain-name mydomain.com
option 150 ip xx.xxx.2.93
netbios-name-server xxx.68.235.228 xxx.68.235.229
!
ip cef
!
interface Ethernet0
description ****Internal Private Network****
ip address 172.16.0.1 255.255.0.0
ip nat inside
!
interface ATM0
no ip address
ip route-cache flow
no ip mroute-cache
load-interval 30
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.35 point-to-point
description ****ATM Subinterface for DSL Access****
no ip mroute-cache
pvc dsl 0/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
interface Dialer1
description ****Logical Outside Interface****
ip address negotiated
ip nat outside
ip mtu 1492
encapsulation ppp
ip tcp adjust-mss 542
dialer pool 1
ppp authentication pap callin
ppp chap refuse
ppp pap sent-username Этот e-mail адрес защищен от спам-ботов, для его просмотра у Вас должен быть включен Javascript password 7 [removed]
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
ip nat inside source list 100 interface dialer1 overload
!
access-list 100 permit ip 172.16.0.0 0.0.255.255 any
!
control-plane
!
rtr responder
banner motd ^C
C i s c o S y s t e m s
UNAUTHORIZED ACCESS TO THIS NETWORK DEVICE IS PROHIBITED.
You must have explicit permission to access or configure this
device. All activities performed on this device are logged and
violations of this policy may result in disciplinary action.
^C
!
line con 0
exec-timeout 0 0
login local
line aux 0
line vty 0 4
exec-timeout 240 0
login local
!
exception memory minimum 786432
scheduler max-task-time 5000
sntp server xxx.5.41.41
sntp server xxx.5.41.40
sntp server xxx.210.169.40
!
end

< Предыдущая   Следующая > Обновлено 19.07.2010 11:44   Последнее на форуме Terms and Conditions | Cisco conf | Support | Contact Us 922-96-07 Design © CCIE | Cisco-conf. All rights reserved.
rss